Connection problems on large high speed connections.

Stian B. Barmen stian at barmen.nu
Wed Apr 27 09:10:52 CEST 2005


> NAT sequence number adjustment is broken since 2.6.11. I believe
> the patch was submitted in after 2.6.12-rc3 had been released.
> 
> But it's an FTP/IRC/etc data channel related bug. It has nothing to do
> with plain HTTP. Do you mean HTTP transfer is also broken or it's just an
> FTP transfer initiated by a web client?
> 

I get the same error if I run http or ftp. No difference.

Here is wget screenshot:

--09:08:01--
http://www.cpan.no/ports/win32/Standard/x86/perl5.00402-bindist04-bc.zip
  (try: 3) => `perl5.00402-bindist04-bc.zip'
Connecting to www.cpan.no[158.36.2.10]:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 6,176,370 (5,278,602 to go) [application/zip]

28%
[++++++++++++==========>                                                             ] 1,754,080    906.44K/s

09:08:02 (904.70 KB/s) - Read error at byte 1754080/6176370 (Connection
reset by peer). Retrying.

You can see that it downloaded a bit, stopped, resumed, stopped again. 

I hate peer sometimes .. :)

Best regards
Stian B. Barmen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2685 bytes
Desc: not available
Url : /pipermail/netfilter/attachments/20050427/501a73ae/smime.bin


More information about the netfilter mailing list