[Bug 1395] Add element fails with Error: Could not process rule: Invalid argument

bugzilla-daemon at netfilter.org bugzilla-daemon at netfilter.org
Fri Jan 10 14:21:29 CET 2020


Phil Sutter <phil at nwl.cc> changed:

           What    |Removed                     |Added
             Status|ASSIGNED                    |NEW

--- Comment #5 from Phil Sutter <phil at nwl.cc> ---
(In reply to Serguei Bezverkhi from comment #4)
> I do not know what to say, the same set of commands does not work on my
> side. I tried on both 5.3.0 and 5.4.10 kernels. 
> I get the same error from the netlink when I use API to talk directly to
> netlink.
> Any debug I could enable to see why it fails in my case?

It also works for me on Gentoo's 5.4.3 kernel. Maybe compare netlink debug

# nft --debug=netlink add element ipv4table no-endpoints-services '{ tcp . . 8989 : goto do_reject }' 
no-endpoints-services ipv4table 0
    element 00000006 6850a8c0 00001d23  : 0 [end]

Did you try using a number instead of 'tcp'? Does it work with a more simple
key instead of the three concatenated types?

You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.netfilter.org/pipermail/netfilter-buglog/attachments/20200110/dc732570/attachment.html>

More information about the netfilter-buglog mailing list