Help with expect : master conntrack not found

Jean-François SMIGIELSKI jf-smig at ibelgique.com
Mon Nov 13 12:32:01 CET 2006


Hi all,

I installed the "conntrack" command line tool on a Debian Linux 4.0 (etch) with a default 2.6.17 kernel. When I tried to execute the test script I found in the SVN repository (/netfilter/trunk/conntrack/test.sh), I had the following error message:

root at plop:~# sh ./test.sh create-expect
NFNETLINK answers: No such file or directory
Operation failed: master conntrack not found

I checked my modules and tried to load some, related to conntrack, netfilter, iptables, ... and many  more modules than reason dictates. In vain. I give you a view on some packages I installed with their versions: conntrack(1.00~beta2-1), iptables (1.3.6.0debian1-2), libnetfilter-conntrack1 (0.0.31-1), libnetfilter-log1 (0.0.13-1), libnetfilter-queue1 (0.0.12-1), libnfnetlink1 (0.0.16-1).

The test script seems to work fine when not dealing with the conntrack table (no error), but goes on error with all the expect table operations.

Can anyone tell me what I missed, please?

Thank you very much!

JF Smigielski


________________________________________________________________________
iBELGIQUE, exprimez-vous !
http://web.ibelgique.com/


More information about the netfilter mailing list