iptables v1.3.3

Damon Gray dgray at internap.com
Fri Aug 26 17:20:57 CEST 2005


Make sure when you compiled 1.3.3 your KERNEL_DIR was set correctly 
because libipt_recent.so will only compile if the .recent-test script in 
the extensions directory finds the file:

$KERNEL_DIR/include/linux/netfilter_ipv4/ipt_recent.h

-Damon-

On Fri, 26 Aug 2005, Thomas Raef wrote:

> I have been running 2.6.11.7 kernel with iptables v1.3.1 and I recently
> downloaded the full v1.3.3 tarball.
>
>
>
> I'm able to make && make install the new iptables v 1.3.3 but when my
> rules load it can't find libipt_recent.so.
>
>
>
> I removed the old iptables first because I was having issues with it
> complaining that I was using iptables v1.3.3 (I'm iptables v1.3.1).
>
>
>
> How do I get libipt_recent.so?
>
>
>
> I do have libipt_recent.c but it's not creating the .so
>
>
>
> I did recompile the kernel with the same options selected as I had
> before. The only thing I'm trying to update is the version of iptables.
>
>
>
> Should I have just patched the v1.3.1?
>
>
>
>
>



More information about the netfilter mailing list