ROUTE woes ?

Brent Clark bclark at eccotours.dyndns.org
Tue Aug 23 20:09:19 CEST 2005


Hi list

I tried at suggestion of:

gate:/usr/src# iptables -t mangle -A FORWARD -p tcp --dport 80 -j ROUTE --oif eth2

But all i get is:
iptables: No chain/target/match by that name

During this time I have been googling and trying to find out why this is failing.

The reason I cant undertand is that I am running debian sarge so therefore the iptables version is v1.3.1

I looked for the module ROUTE and it defiantly if there.

ROUTE target v1.11 options:
     --oif       ifname          Route packet through `ifname' network interface
     --iif       ifname          Change packet's incoming interface to `ifname'
     --gw        ip              Route packet via this gateway `ip'
     --continue                  Route packet and continue traversing the
                                 rules. Not valid with --iif or --tee.
     --tee                       Duplicate packet, route the duplicate,
                                 continue traversing with original packet.
                                 Not valid with --iif or --continue.

So on looking at the kernel src

I worked out that I had not added or  complied in multipath, I have now

gate:/usr/src/linux# cat .config | grep ROUTE
CONFIG_IP_ADVANCED_ROUTER=y
CONFIG_IP_ROUTE_FWMARK=y
CONFIG_IP_ROUTE_MULTIPATH=y
CONFIG_IP_ROUTE_VERBOSE=y

and too this day I still am getting

gate:/usr/src/linux# iptables -t mangle -A FORWARD -p tcp --dport 80 -j ROUTE --oif eth2
iptables: No chain/target/match by that name
gate:/usr/src/linux#

If anyone can help in anyway, I would be most greatful.

Kind Regards, and again thanks in advance.

Brent Clark




More information about the netfilter mailing list