compilation problem rhat el4

Rosario Pingaro rpingar at italycom.it
Sat Aug 13 18:59:25 CEST 2005


I would like to have the l7-filter funtionality on my redhat el4.

So I downloada the latest iptable-1.3.3 and the last patch from l7-filter

But trying to compile the patched files I get this error:
#error including kernel header in userspace; use the glibc headers instead! make: *** [extensions/libipt_layer7_sh.o] Error 1

I found several posts about it without any useful solution.
In fact if I use "KERNEL_DIR=/usr" I get the header from userspace so everything is compiled but not the layer7 module "libipt_layer7.so".

I checked if everything into the kernel (about packet filtering and layer7) is activated, and there, everythings seems fine.

Just to note that "libipt_layer7.h" is not present on my system. 

Where is my problem?

Thanks
Rosario


More information about the netfilter mailing list