Problems with iptables 0.15

Paul Rusty Russell Paul.Russell@rustcorp.com.au
Tue, 31 Aug 1999 14:57:42 -0700


In message <m2hflipmso.fsf@barnowl.demon.co.uk> you write:
> I am using Linux kernel 2.3.15 and am exploring the (new) iptables as
> a replacement for ipchains. I have found a few problems (or I am doing
> something wrong) 
> 
> With netfilter 0.15
> 
> 1) rules such as "iptables -i ppp+ ...." do not work, but specifying
>    -i ppp0 works.

Thanks!  This was a bug, will be fixed in 0.1.6.

> 2) when using the extended LOG target, the option --log-limit which is
>    mentioned in the HowTo is not accepted.

I put this in my testsuite, and it seems to work here?  See below.

> 3) Is there a limit as to the number of rules? I have tried writing a
>    script to start iptables, and have encountered some problems. I am
>    including my script below. As written here it seems to work
>    fine. If I remove the comment from ANY one of the (commented out)
>    rules then all of the commands are accepted, but "iptables -L"
>    seems to be looping

No limit on #.  I can't duplicate this either; I tried uncommenting
everything, then just uncommenting the first one.  Perhaps you are
seeing some library corruption?  Try doing make install again.

What libc (ls -l /lib/libc.so*) and what compiler (gcc --version).  I
am using:

# ls -l /lib/libc.so*
lrwxrwxrwx   1 root     root           13 Aug 30 14:30 /lib/libc.so.6 -> libc-2.1.2.so
# gcc --version
2.95.1
# 

Confused,
Rusty.
--
Hacking time.