problems applying ipset patch

Andrea andang76 at
Wed May 23 09:47:02 CEST 2007

I've tried to apply the ipset patch in my CentOS 4.4 distribution, 
without success.

I've followed instructions here 
   (CentOS Kernel Compile) and here (ipset patch apply).

The patch is applied successfully, but when I try to recompile, I obtain 
these errors (after a long list of compiled files):

   LD      .tmp_vmlinux1
net/built-in.o(.init.text+0x16f1): In function `ipt_ipset_init':
net/ipv4/netfilter/ipt_set.c:133: undefined reference to `xt_register_match'
net/built-in.o(.init.text+0x1700): In function `ipt_SET_init':
net/ipv4/netfilter/ipt_SET.c:151: undefined reference to 
net/built-in.o(.exit.text+0x41): In function `ipt_ipset_fini':
net/ipv4/netfilter/ipt_set.c:138: undefined reference to 
net/built-in.o(.exit.text+0x50): In function `ipt_SET_fini':
net/ipv4/netfilter/ipt_SET.c:156: undefined reference to 
make: *** [.tmp_vmlinux1] Error 1

I've tried twice, using two combinations of kernel (downloaded from and patch-o-matic (downloaded first time from, second from patch-o-matic snaptshots).

I've applied only the ipset patch (launching only the  ./runme set 
command, just as explained in the ipset site).

Maybe do I need to apply other patches from patch-o-matic?

Thanks for the help

More information about the netfilter-devel mailing list