[Bug 1337] New: NETMAP feature, using a displaced mask fail.

bugzilla-daemon at netfilter.org bugzilla-daemon at netfilter.org
Thu May 9 14:55:11 CEST 2019


            Bug ID: 1337
           Summary: NETMAP feature, using a displaced mask fail.
           Product: iptables
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P5
         Component: iptables
          Assignee: netfilter-buglog at lists.netfilter.org
          Reporter: gperezbrun at gmail.com

    I am trying to map displaced masks. In particular, this example.

Original destination Subnets.
FROM   00001010.00001010.00000000.11101 000
TO 00001010.00001010.11111111.11101 000
MASK    11111111.11111111.00000000.11111 000

Translated destination Subnets.
FROM     10101100.00011100.00000000.00000 000
TO   10101100.00011100.00000111.11111 000
MASK     11111111.11111111.11111000.00000 000

     So, to achive that I run:
# iptables -t nat -A PREROUTING -d -j NETMAP --to

    But IPTABLES shows another destination MASK:
# iptables -t nat -L -nv
Chain PREROUTING (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination 
    0     0 NETMAP     all  --  *      *  

    This was run on many linux distros with same result. Can somebody help me
with this? It's the correct behavior?
    Thanks a lot for your time and sorry about my english.

You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.netfilter.org/pipermail/netfilter-buglog/attachments/20190509/e05a8f4f/attachment.html>

More information about the netfilter-buglog mailing list