[Bug 916] Build failure on Slackware 14.1 (./configure rejects libreadline.so)

bugzilla-daemon at netfilter.org bugzilla-daemon at netfilter.org
Sat Mar 12 14:36:05 CET 2016


--- Comment #6 from duncan_roe at acslink.net.au ---
I still see

checking for readline in -lreadline... no
configure: error: No suitable version of libreadline found

Just to be clear, I ran ./autogen.sh as Pablo Neira Ayuso advised in Comment 3.
After that, there was no console output from autoconfig.

I ran libtoolize --force as Piyush Pangtey advised in comment 5.
The last line output by libtoolize is:
  libtoolize: Remember to add `LT_INIT' to configure.ac.
so I did that:

00:03:12$ git diff     
diff --git a/configure.ac b/configure.ac
index 0d7e6ed..e76e646 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.



If I apply  patch_-p0_file (needs fuzz factor 3 now) it all works:

00:25:16$ git checkout -- configure.ac
00:27:14$ cat configure.ac.patch|patch -F 3 -p0
patching file configure.ac
Hunk #1 succeeded at 71 with fuzz 3.
00:27:35$ autoconf
00:27:47$ ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/man
checking build system type... i686-pc-linux-gnu
nft configuration:
  cli support:                  yes
  enable debugging:             no
  use mini-gmp:                 no
00:27:57$ git diff
diff --git a/configure.ac b/configure.ac
index 0d7e6ed..901c971 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,9 @@ AM_CONDITIONAL([BUILD_PDF], [test "$DBLATEX" == "found"])

 # Checks for libraries.
 PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
+AC_CHECK_LIB([ncurses], [tputs], ,
+            AC_MSG_ERROR([No suitable version of libncurses found]))
 PKG_CHECK_MODULES([LIBNFTNL], [libnftnl >= 1.0.5])

 AC_ARG_WITH([mini-gmp], [AS_HELP_STRING([--with-mini-gmp],

You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.netfilter.org/pipermail/netfilter-buglog/attachments/20160312/157b9aed/attachment.html>

More information about the netfilter-buglog mailing list