[Bug 916] Build failure on Slackware 14.1 (./configure rejects libreadline.so)

bugzilla-daemon at netfilter.org bugzilla-daemon at netfilter.org
Thu Mar 10 18:21:38 CET 2016


Piyush Pangtey <gokuvsvegita at gmail.com> changed:

           What    |Removed                     |Added
             Status|ASSIGNED                    |NEW
                 CC|                            |gokuvsvegita at gmail.com

--- Comment #5 from Piyush Pangtey <gokuvsvegita at gmail.com> ---
(In reply to duncan_roe from comment #2)
> configure.ac still doesn't mention ncurses.This only ever was a problem with
> certain arguments to ./configure, e.g. ./configure --disable-debug. It did
> not break the Slackware build.
> To check whether I could reproduce the problem, I cloned the git repo. When
> I ran autoconfig, I got:
> configure.ac:13: error: possibly undefined macro: AM_INIT_AUTOMAKE
>       If this token and others are legitimate, please use m4_pattern_allow.
>       See the Autoconf documentation.
> configure.ac:30: error: possibly undefined macro: AM_CONDITIONAL
> configure.ac:37: error: possibly undefined macro: AM_PROG_LEX
> When I then ran ./configure --disable-debug, I got:
> configure: error: cannot find install-sh, install.sh, or shtool in build-aux
> "."/build-aux
> Please advise what I should have run - I'm not a regular user of auto*

Try GNU libtool . (git://git.savannah.gnu.org/libtool.git) 
and run 

$ libtoolize --force

before executing autoconf script.

You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.netfilter.org/pipermail/netfilter-buglog/attachments/20160310/3f2c5e22/attachment.html>

More information about the netfilter-buglog mailing list