[Bug 849] New: 172.245.13.X doesn't appear properly in output of iptables -L

bugzilla-daemon at netfilter.org bugzilla-daemon at netfilter.org
Thu Aug 29 04:14:10 CEST 2013


           Summary: 172.245.13.X doesn't appear properly in output of
                    iptables -L
           Product: iptables
           Version: 1.4.x
          Platform: x86_64
        OS/Version: Debian GNU/Linux
            Status: NEW
          Severity: minor
          Priority: P5
         Component: iptables
        AssignedTo: netfilter-buglog at lists.netfilter.org
        ReportedBy: jtbock at mailzone.com
   Estimated Hours: 0.0

Tried to dynamically add to my list via "iptables -I INPUT -s
"" -j DROP", and the command appeared to work fine.  But then
when I tried to verify via "iptables -L", the rule shows up with only a "." in
the source field.  The fourth octet can be anything; same result.  If the
first, second, or third octet varies, then the result of iptables -L is as
expected.  But something like shows up in iptables -L as "./24"

This was initially disconcerting, as it seemed the block I was trying to drop
was not being accepted.  However, it appears to be a display problem only. 
When I did an iptables-save, the rule appeared in the output as it was entered.

I tried this on multiple machines (CentOS, RedHat, Ubuntu, Debian) of varying
OS vintages, and on x86_64 and i386. It was reproducible on all of them.  The
most recent is the latest Debian (7.0.0) with iptables v1.4.14.

Hope I'm not missing something obvious.

Thank you,

Configure bugmail: https://bugzilla.netfilter.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the netfilter-buglog mailing list